re = /(\S)\r?\n(\S)/m
str = 'Сайт.com
логин:пароль
логин:пароль
Другойсайт.com
логин:пароль
логин:пароль
логин:пароль
логин:пароль
Ещёодинсайт.com
логин:пароль
логин:пароль
логин:пароль'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result