#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\S)\r?\n(\S)"
Local $sString = "Сайт.com" & @CRLF & _
                "логин:пароль" & @CRLF & _
                "логин:пароль" & @CRLF & _
                "    " & @CRLF & _
                "Другойсайт.com" & @CRLF & _
                "логин:пароль" & @CRLF & _
                "логин:пароль" & @CRLF & _
                "логин:пароль" & @CRLF & _
                "логин:пароль" & @CRLF & _
                "    " & @CRLF & _
                "Ещёодинсайт.com" & @CRLF & _
                "логин:пароль" & @CRLF & _
                "логин:пароль" & @CRLF & _
                "логин:пароль"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)