import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S)\\r?\\n(\\S)";
final String string = "Сайт.com\n"
+ "логин:пароль\n"
+ "логин:пароль\n"
+ " \n"
+ "Другойсайт.com\n"
+ "логин:пароль\n"
+ "логин:пароль\n"
+ "логин:пароль\n"
+ "логин:пароль\n"
+ " \n"
+ "Ещёодинсайт.com\n"
+ "логин:пароль\n"
+ "логин:пароль\n"
+ "логин:пароль";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}