const regex = /(\S)\r?\n(\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S)\\r?\\n(\\S)', 'gm')
const str = `Сайт.com
логин:пароль
логин:пароль
Другойсайт.com
логин:пароль
логин:пароль
логин:пароль
логин:пароль
Ещёодинсайт.com
логин:пароль
логин:пароль
логин:пароль`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);