# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\\]//g;t' <<< "<li class=\\"product-col\\"><div class=\\"product-inner\\"><div class=\\"product-image\\"><a href=\\"https:\/\/test.com\/\\"><img width=\\"300\\" height=\\"300\\" src=\\"https:\/\/test.com\/imgs\/uploads\/00894771000341_front-300x300.jpg\\" class=\\"img-fluid\\" alt=\\"\\"></a></div>Test Product</div></li>"