// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\\]").unwrap();
let string = "<li class=\\\"product-col\\\"><div class=\\\"product-inner\\\"><div class=\\\"product-image\\\"><a href=\\\"https:\\/\\/test.com\\/\\\"><img width=\\\"300\\\" height=\\\"300\\\" src=\\\"https:\\/\\/test.com\\/imgs\\/uploads\\/00894771000341_front-300x300.jpg\\\" class=\\\"img-fluid\\\" alt=\\\"\\\"></a></div>Test Product</div></li>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}