import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\\\]";
final String string = "<li class=\\\"product-col\\\"><div class=\\\"product-inner\\\"><div class=\\\"product-image\\\"><a href=\\\"https:\\/\\/test.com\\/\\\"><img width=\\\"300\\\" height=\\\"300\\\" src=\\\"https:\\/\\/test.com\\/imgs\\/uploads\\/00894771000341_front-300x300.jpg\\\" class=\\\"img-fluid\\\" alt=\\\"\\\"></a></div>Test Product</div></li>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}