import re
regex = re.compile(r"[\\]")
test_str = "<li class=\\\"product-col\\\"><div class=\\\"product-inner\\\"><div class=\\\"product-image\\\"><a href=\\\"https:\\/\\/test.com\\/\\\"><img width=\\\"300\\\" height=\\\"300\\\" src=\\\"https:\\/\\/test.com\\/imgs\\/uploads\\/00894771000341_front-300x300.jpg\\\" class=\\\"img-fluid\\\" alt=\\\"\\\"></a></div>Test Product</div></li>"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)