import Foundation
let pattern = #"[\\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<li class=\"product-col\"><div class=\"product-inner\"><div class=\"product-image\"><a href=\"https:\/\/test.com\/\"><img width=\"300\" height=\"300\" src=\"https:\/\/test.com\/imgs\/uploads\/00894771000341_front-300x300.jpg\" class=\"img-fluid\" alt=\"\"></a></div>Test Product</div></li>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)