#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[\/]assets[\/].*\.(png|jpe?g|gif|json|js)$"
Local $sString = "./assets/example.js" & @CRLF & _
"./assets/recursive-directory/example/exampleTwo.json" & @CRLF & _
"../assets/recursive-directory/example/exampleThree.json" & @CRLF & _
"../../../assets/recursive-directory/example/exampleThree.json" & @CRLF & _
"C:\Users\user1\project\assets\game-assets\translates.json"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")