import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\/]assets[\\/].*\\.(png|jpe?g|gif|json|js)$";
final String string = "./assets/example.js\n"
+ "./assets/recursive-directory/example/exampleTwo.json\n"
+ "../assets/recursive-directory/example/exampleThree.json\n"
+ "../../../assets/recursive-directory/example/exampleThree.json\n"
+ "C:\\Users\\user1\\project\\assets\\game-assets\\translates.json";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}