using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\/]assets[\/].*\.(png|jpe?g|gif|json|js)$";
string input = @"./assets/example.js
./assets/recursive-directory/example/exampleTwo.json
../assets/recursive-directory/example/exampleThree.json
../../../assets/recursive-directory/example/exampleThree.json
C:\Users\user1\project\assets\game-assets\translates.json";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}