const regex = /[\/]assets[\/].*\.(png|jpe?g|gif|json|js)$/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\\/]assets[\\\/].*\\.(png|jpe?g|gif|json|js)$', 'mgi')
const str = `./assets/example.js
./assets/recursive-directory/example/exampleTwo.json
../assets/recursive-directory/example/exampleThree.json
../../../assets/recursive-directory/example/exampleThree.json
C:\\Users\\user1\\project\\assets\\game-assets\\translates.json`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}