re = /[\/]assets[\/].*\.(png|jpe?g|gif|json|js)$/mi
str = './assets/example.js
./assets/recursive-directory/example/exampleTwo.json
../assets/recursive-directory/example/exampleThree.json
../../../assets/recursive-directory/example/exampleThree.json
C:\\Users\\user1\\project\\assets\\game-assets\\translates.json'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end