package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[\/]assets[\/].*\.(png|jpe?g|gif|json|js)$`)
var str = `./assets/example.js
./assets/recursive-directory/example/exampleTwo.json
../assets/recursive-directory/example/exampleThree.json
../../../assets/recursive-directory/example/exampleThree.json
C:\Users\user1\project\assets\game-assets\translates.json`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}