import re
regex = re.compile(r"[\/]assets[\/].*\.(png|jpe?g|gif|json|js)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("./assets/example.js\n"
"./assets/recursive-directory/example/exampleTwo.json\n"
"../assets/recursive-directory/example/exampleThree.json\n"
"../../../assets/recursive-directory/example/exampleThree.json\n"
"C:\\Users\\user1\\project\\assets\\game-assets\\translates.json")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")