use strict;
my $str = './assets/example.js
./assets/recursive-directory/example/exampleTwo.json
../assets/recursive-directory/example/exampleThree.json
../../../assets/recursive-directory/example/exampleThree.json
C:\\Users\\user1\\project\\assets\\game-assets\\translates.json';
my $regex = qr/[\/]assets[\/].*\.(png|jpe?g|gif|json|js)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}