#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)%[^%:]*:\s(.+)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"I am trying to make an regex search that will get all text after expressio." & @CRLF & _
"" & @CRLF & _
"(?<=%([\s\S]?):\s).$ I use this regex but in python it not work." & @CRLF & _
"" & @CRLF & _
"Example:" & @CRLF & _
"" & @CRLF & _
"group-6-54574 - it is a dynamic text" & @CRLF & _
"" & @CRLF & _
"May 12 2021 11:07:56 %group-6-54574: some text that i need"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")