# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"%[^%:]*:\s(.+)"
test_str = ("\n\n"
"I am trying to make an regex search that will get all text after expressio.\n\n"
"(?<=%([\\s\\S]?):\\s).$ I use this regex but in python it not work.\n\n"
"Example:\n\n"
"group-6-54574 - it is a dynamic text\n\n"
"May 12 2021 11:07:56 %group-6-54574: some text that i need")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.