package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)%[^%:]*:\s(.+)`)
var str = `
I am trying to make an regex search that will get all text after expressio.
(?<=%([\s\S]?):\s).$ I use this regex but in python it not work.
Example:
group-6-54574 - it is a dynamic text
May 12 2021 11:07:56 %group-6-54574: some text that i need`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}