const regex = new RegExp('%[^%:]*:\\s(.+)', 'gm')
const str = `
I am trying to make an regex search that will get all text after expressio.
(?<=%([\\s\\S]?):\\s).\$ I use this regex but in python it not work.
Example:
group-6-54574 - it is a dynamic text
May 12 2021 11:07:56 %group-6-54574: some text that i need`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}