using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%[^%:]*:\s(.+)";
string input = @"
I am trying to make an regex search that will get all text after expressio.
(?<=%([\s\S]?):\s).$ I use this regex but in python it not work.
Example:
group-6-54574 - it is a dynamic text
May 12 2021 11:07:56 %group-6-54574: some text that i need";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}