import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "%[^%:]*:\\s(.+)";
final String string = "\n\n"
+ "I am trying to make an regex search that will get all text after expressio.\n\n"
+ "(?<=%([\\s\\S]?):\\s).$ I use this regex but in python it not work.\n\n"
+ "Example:\n\n"
+ "group-6-54574 - it is a dynamic text\n\n"
+ "May 12 2021 11:07:56 %group-6-54574: some text that i need";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}