// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)%[^%:]*:\s(.+)").unwrap();
let string = "
I am trying to make an regex search that will get all text after expressio.
(?<=%([\\s\\S]?):\\s).$ I use this regex but in python it not work.
Example:
group-6-54574 - it is a dynamic text
May 12 2021 11:07:56 %group-6-54574: some text that i need";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}