using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(!\[.*?]\()(?:https:\/\/example\.com\/*)?(.*?)(\))";
string substitution = @"$1https://example.com/$2?raw=true$3";
string input = @"Some text 
some text  some other text
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}