use strict;
my $str = 'Some text 
some text  some other text
';
my $regex = qr/(!\[.*?]\()(?:https:\/\/example\.com\/*)?(.*?)(\))/mp;
my $subst = '$1https://example.com/$2?raw=true$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";