re = /(!\[.*?]\()(?:https:\/\/example\.com\/*)?(.*?)(\))/m
str = 'Some text 
some text  some other text
'
subst = '$1https://example.com/$2?raw=true$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result