import Foundation
let pattern = #"(!\[.*?]\()(?:https:\/\/example\.com\/*)?(.*?)(\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Some text 
some text  some other text

"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1https://example.com/$2?raw=true$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)