$re = '/(!\[.*?]\()(?:https:\/\/example\.com\/*)?(.*?)(\))/m';
$str = 'Some text 
some text  some other text
';
$subst = "$1https://example.com/$2?raw=true$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;