import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(!\\[.*?]\\()(?:https:\\/\\/example\\.com\\/*)?(.*?)(\\))";
final String string = "Some text  \n"
+ "some text  some other text \n"
+ " ";
final String subst = "$1https://example.com/$2?raw=true$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}