// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(!\[.*?]\()(?:https:\/\/example\.com\/*)?(.*?)(\))").unwrap();
let string = "Some text 
some text  some other text
";
let substitution = "$1https://example.com/$2?raw=true$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}