#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([T\$])([-+]?)(\d*)(\s?)(\d+)(\,)(\d+)$"
Local $sString = "!Type:Bank" & @CRLF & _
"D2023-11-20" & @CRLF & _
"T-2 043,51" & @CRLF & _
"PCARTE 19/11/23 LEROY MERLIN" & @CRLF & _
"LBricolage et jardinage" & @CRLF & _
"^" & @CRLF & _
""
Local $sSubst = "$1$2$3$5.$7"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)