using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([T\$])([-+]?)(\d*)(\s?)(\d+)(\,)(\d+)$";
string substitution = @"$1$2$3$5.$7";
string input = @"!Type:Bank
D2023-11-20
T-2 043,51
PCARTE 19/11/23 LEROY MERLIN
LBricolage et jardinage
^
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}