import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([T\\$])([-+]?)(\\d*)(\\s?)(\\d+)(\\,)(\\d+)$";
final String string = "!Type:Bank\n"
+ "D2023-11-20\n"
+ "T-2 043,51\n"
+ "PCARTE 19/11/23 LEROY MERLIN\n"
+ "LBricolage et jardinage\n"
+ "^\n";
final String subst = "$1$2$3$5.$7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}