import re
regex = re.compile(r"^([T\$])([-+]?)(\d*)(\s?)(\d+)(\,)(\d+)$", flags=re.MULTILINE)
test_str = ("!Type:Bank\n"
"D2023-11-20\n"
"T-2 043,51\n"
"PCARTE 19/11/23 LEROY MERLIN\n"
"LBricolage et jardinage\n"
"^\n")
subst = "$1$2$3$5.$7"
result = regex.sub(subst, test_str)
if result:
print(result)