$re = '/^([T\$])([-+]?)(\d*)(\s?)(\d+)(\,)(\d+)$/m';
$str = '!Type:Bank
D2023-11-20
T-2 043,51
PCARTE 19/11/23 LEROY MERLIN
LBricolage et jardinage
^
';
$subst = "$1$2$3$5.$7";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;