# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/L(?=\d{4}$)/A/gm;t' <<< "Some Text L1234
Some Other Text L5587"