use strict;
my $str = 'Some Text L1234
Some Other Text L5587';
my $regex = qr/L(?=\d{4}$)/mp;
my $subst = 'A';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";