using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"L(?=\d{4}$)";
string substitution = @"A";
string input = @"Some Text L1234
Some Other Text L5587";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}