const regex = /L(?=\d{4}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('L(?=\\d{4}$)', 'gm')
const str = `Some Text L1234
Some Other Text L5587`;
const subst = `A`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);