#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)L(?=\d{4}$)"
Local $sString = "Some Text L1234" & @CRLF & _
"Some Other Text L5587"
Local $sSubst = "A"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)