import Foundation
let pattern = #"L(?=\d{4}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Some Text L1234
Some Other Text L5587
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"A"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)