re = /L(?=\d{4}$)/m
str = 'Some Text L1234
Some Other Text L5587'
subst = 'A'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result