using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[01]\d?|2[0-3]?)(?::(?:[0-5]\d?)?)?$";
string input = @"0
1
12
12:
12:3
12:30
1:
1:3
1:30
25:00
25
253";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}