const regex = /^(?:[01]\d?|2[0-3]?)(?::(?:[0-5]\d?)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[01]\\d?|2[0-3]?)(?::(?:[0-5]\\d?)?)?$', 'gm')
const str = `0
1
12
12:
12:3
12:30
1:
1:3
1:30
25:00
25
253`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}