import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[01]\\d?|2[0-3]?)(?::(?:[0-5]\\d?)?)?$";
final String string = "0\n"
+ "1\n"
+ "12\n"
+ "12:\n"
+ "12:3\n"
+ "12:30\n"
+ "1:\n"
+ "1:3\n"
+ "1:30\n\n"
+ "25:00\n"
+ "25\n"
+ "253";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}