$re = '/^(?:[01]\d?|2[0-3]?)(?::(?:[0-5]\d?)?)?$/m';
$str = '0
1
12
12:
12:3
12:30
1:
1:3
1:30
25:00
25
253';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);