using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^HAD(?:-OR(?:AAS|BTD)[0-9]{5,7}){1,2}$";
string input = @"HAD-ORAAS0001545-ORBTD0003457
HAD-ORBTD0001545-ORAAS0003457";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}