import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^HAD(?:-OR(?:AAS|BTD)[0-9]{5,7}){1,2}$";
final String string = "HAD-ORAAS0001545-ORBTD0003457\n"
+ "HAD-ORBTD0001545-ORAAS0003457";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}