re = /^HAD(?:-OR(?:AAS|BTD)[0-9]{5,7}){1,2}$/m
str = 'HAD-ORAAS0001545-ORBTD0003457
HAD-ORBTD0001545-ORAAS0003457'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end